March 28th, 2008

easterflowers

(no subject)

firelion, just so you know, AIM doesn't like my wireless internet thingamabob, and every other IM program requires WindowsXP or Vista, and I've got Windows98.

Simply put, I won't be able to IM until I get a new computer.
  • Current Mood
    annoyed annoyed