Tara (ravenclawed) wrote,
Tara
ravenclawed

firelion, just so you know, AIM doesn't like my wireless internet thingamabob, and every other IM program requires WindowsXP or Vista, and I've got Windows98.

Simply put, I won't be able to IM until I get a new computer.
Subscribe
  • Post a new comment

    Error

    default userpic
    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 4 comments